ZViewer 2.0.1.5


#64

This software appears to be very rushed, and needs some polish. I am wasting a third of the screen with white space that shows all the Camera IP’s to anyone looking at the monitor, cannot maximize it to full screen, have to add the cameras back EVERY time the software starts, etc, etc… The old version worked perfect - why not roll back to that version and allow the encryption? This is maddening!


#65

I’m sorry but, it seems to me to be obvious (if it isn’t to you please let me know what I’m missing), that the users of Zviewer want the option to use this software as an “in-house” only option that worked like it did before the encryption “fix” was applied. I do not want to view my cameras on a smart phone. I only have 32 cameras in one location and plan to add 3 more NVRs with ip cameras that are all connected to my LAN. Using a phone (no matter how large the screen) is NOT an option. It seems to me that I am not alone in this. If you want to view your cameras via the net then, by all means you should be able to do that and the option to do that is fine. There are those of us who liked things the way they were. It is not a viable option to have 32 plus cameras recording to YOUR servers (which btw, you don’t need my video either). Why we can’t have it either way has more than a few beating their heads against the wall, myself included.


#66

It has been recommended to the development team to create a local only software option. At this point maintaining the security of the encryption keys is the argument for requiring the external connection.

I believe the not saving the layout is a failure of the rush to release.

@danwill A P2P connection doesn’t stream the video through our servers, or record to our servers. The server essentially acts as a meeting point, and then video is streamed directly to the device. We don’t currently have servers that would be robust enough to stream or record the video images from all of the devices.


#67

I followed to a “T” and no joy.

I’ll keep trying. Unfortunately, I have two NVRs an 8ch with new FW and a 4ch with old software. For now I only use 3 of the 8 channels but four more of the channels are brought over from the 4ch NVR. I don’t like that, but for now it is what it is.

In step 2 when almost adding by IP do you put in the IP address, username and password and NOT hit add?


#68





Zviewer - Can't use it -SOLVED
#69

And here are the log files to back this up, if you look in yours you will see it connects and immediately disconnects. Look at the time-stamps. Third try it magically stays connected without the thread exits. I should note this only works locally patty. This never works remotely by device ID, it always returns invalid password. I even put this device directly connected to the internet, no firewall and it never works outside of the local LAN.

2017-6-21 18:48:29.411 [DeviceIp:192.168.1.120 Chn:0]Decoder Thread Start!
2017-6-21 18:48:29.411 [DeviceIp:192.168.1.120 Chn:0] Connect ok
2017-6-21 18:48:29.411 [DeviceIp:192.168.1.120 Chn:0] Send Read Request Successed!
2017-6-21 18:48:29.505 [DeviceIp:192.168.1.120 Chn:1]Decoder Thread Start!
2017-6-21 18:48:29.505 [DeviceIp:192.168.1.120 Chn:1] Connect ok
2017-6-21 18:48:29.505 [DeviceIp:192.168.1.120 Chn:1] Send Read Request Successed!
2017-6-21 18:48:29.598 [DeviceIp:192.168.1.120 Chn:2]Decoder Thread Start!
2017-6-21 18:48:29.598 [DeviceIp:192.168.1.120 Chn:2] Connect ok
2017-6-21 18:48:29.598 [DeviceIp:192.168.1.120 Chn:2] Send Read Request Successed!
2017-6-21 18:48:29.692 [DeviceIp:192.168.1.120 Chn:3]Decoder Thread Start!
2017-6-21 18:48:29.692 [DeviceIp:192.168.1.120 Chn:3] Connect ok
2017-6-21 18:48:29.692 [DeviceIp:192.168.1.120 Chn:3] Send Read Request Successed!
2017-6-21 18:48:29.707 [DeviceIp:192.168.1.120 Chn:0] Decoder Thread Exit!
2017-6-21 18:48:29.723 [DeviceIp:192.168.1.120 Chn:1] Decoder Thread Exit!
2017-6-21 18:48:29.723 [DeviceIp:192.168.1.120 Chn:2] Decoder Thread Exit!
2017-6-21 18:48:29.723 [DeviceIp:192.168.1.120 Chn:3] Decoder Thread Exit!
2017-6-21 18:48:31.314 [DeviceIp:192.168.1.120 Chn:0]Decoder Thread Start!
2017-6-21 18:48:31.314 [DeviceIp:192.168.1.120 Chn:0] Connect ok
2017-6-21 18:48:31.314 [DeviceIp:192.168.1.120 Chn:0] Send Read Request Successed!
2017-6-21 18:48:31.330 [DeviceIp:192.168.1.120 Chn:1]Decoder Thread Start!
2017-6-21 18:48:31.330 [DeviceIp:192.168.1.120 Chn:1] Connect ok
2017-6-21 18:48:31.330 [DeviceIp:192.168.1.120 Chn:1] Send Read Request Successed!
2017-6-21 18:48:31.330 [DeviceIp:192.168.1.120 Chn:2] Connect ok
2017-6-21 18:48:31.345 [DeviceIp:192.168.1.120 Chn:2] Send Read Request Successed!
2017-6-21 18:48:31.361 [DeviceIp:192.168.1.120 Chn:3] Connect ok
2017-6-21 18:48:31.377 [DeviceIp:192.168.1.120 Chn:3] Send Read Request Successed!
2017-6-21 18:48:31.377 [DeviceIp:192.168.1.120 Chn:3]Decoder Thread Start!
2017-6-21 18:48:31.377 [DeviceIp:192.168.1.120 Chn:2]Decoder Thread Start!


#70

I’ll try again. Interestingly the 4ch unit with the older FW shows the NVR and IPC. However, the newer 8ch only shows the NVR and you never see any IPC cameras.

I can confirm that because my netwatcher software shows the older NVR and 4 cameras each with their own IP addresses. However the newer FW 8ch only shows the NVR. The individual cameras never show anywhere. Strange.


#71

@starship if you aren’t getting remote access, that means that the UPNP port isn’t open. Good security has you turn UPNP off, so you will need to open the NVR’s UPNP ports manually through your router.


#72

I appreciate the feedback but if you read my previous response, “This never works remotely by device ID, it always returns login failed. I even put this device directly connected to the internet, no firewall and it never works outside of the local LAN.”

I put the device directly on the internet, statically assigned with a publicly addressable COX address with no firewall turned on and no DNS issues. If i connect to the device by IP and start streaming live you can actually see the packets coming down but no video ever displays. If i click on the take snapshot it works and i get a picture but no live video ever displays.

If i add via deviceID it always says “Login Failed”, again this is with the NVR directly connected to the world and no firewall involved.


#73

If the device is statically addressed a public IP address, it will not be able to connect to our servers, and won’t view cameras through the mobile app. This makes it so that the ID doesn’t reference anything. So that won’t work.

If it is connected directly to a modem (that is not ALSO a router), it also won’t stream any cameras, as the cameras are required to be on the local network with the NVR.

My response is still the same, open the UPNP ports. Please at least attempt my suggestions prior to insisting they can’t work.


#74

I have done as you asked, I created port forward entries for all the UPNP ports listed on the NVR. I also created “any any” rules for these ports on the firewall to the NVR. The results on my end are the same. No video. I appreciate the help, at this point I will live with the meshare application and seek another option for my business partners surveillance needs.




#75

Is it just my computer or is the link to the zviewer software no longer functional???


#76

Being a new user I cant start a new topic so I hope Im not hijacking this tread. I have a ZMD-DD-SBN8 that I use and older version of Zviewer with on my iPhone and Android tablet. With iOS11 this version of Zviewer will no longer be supported. I have tried a few other ZModo apps and they cant seem to connect to my system. Will ZViewer 2.0.1.5 work with my system and iOS11?


#77

@goochman ZViewer 2.0.1.5 is software for a PC.

The current version for iOS is 1.0.4. You would simply search Zviewer and then download it from the app store


#78

I still cannot access my NVR outside of my home using zviewer. I have all ports that Zmodo claims is required forwarded to the NVR I can log in with the viewer and look at recorded video all I want except sometimes it does a loop-back thing would show just start looping about 10 to 20 seconds of video which is annoying. However I cannot get live video to work at all. Not only do I have the proper ports open but I also have UPnP enabled in my router and I know that works due to the fact that I have multiple PlayStation 4 that use UPnP to work as well as other devices in the home that are set up strictly over UPnP and work just fine. But with the current release of the zviewer software it will not pull any live video only recorded video and that is if it doesn’t start looping video. However inside my home I can use the viewer and pull up live video no problem I have a monitoring station when I’m down in the basement that is running zviewer and can stream the live video Non-Stop. The one that is inside my network has to pull the individual IP’s of the cameras for it to work. I did try to add Mine by device ID as you have stated many times however two things happen one is that I keep getting login failure and I have tried the login of the NVR self I also tried my niece share login wondering if that might possibly be the problem but I’m pretty sure the NVR username and password as one is needed but it does not work. However if I put in my Dynamic DNS and then put in my NVR username and password it signs in no problem. And I’m using the device ID that is on the bottom of the NVR since I was told that one point they thought I was using the wrong one I just wanted to clarify the device ID that I was using. Is there any way for those of us that are having this much trouble to be able to go back to not having to have this encrypted connection that is causing these kinds of problems.


#79

Hi, I’m one of the users who had the ZViewer Windows application setup for remote viewing working fine last year before the firmware upgrade fiasco that caused it to stop working. I decided to revisit this after seeing this new version of the ZViewer application and decided to give it a try again. I have the ZM-SS714-1TB system (which includes the ZP-NE14-S NVR). The NVR is on firmware version V40.0.3.02.

I see the current ZViewer for PC version that’s available at http://surveillance.zmodo.com/support-software is 2.0.1.6. I’m not sure what’s the difference between 2.0.1.5 and 2.0.1.6. Is there any change log available?

Anyways, after installing it, I found I could playback video from each of the 4 cameras fine. But I cannot view live video at all. When I drag the cameras under the device list of my NVR to the rectangles in the live video screen (like how I did it last year on the older version of ZViewer before the newer firmware rendered it useless), nothing is shown.

I am trying to do this remotely outside the LAN that the NVR is on. I see some references in this thread to add by device ID, but this is not applicable for my current use case. And in ZViewer 2.0.1.6, I don’t even see any option to add by device ID (in the Add Device dialog, only LAN Search, IP Search, and DNS Search are available).

If I get a chance to get on the LAN that the NVR is on, I’ll try using ZViewer again then. But it’s more important for me to be able to view live video remotely with it, and this isn’t working. Has anyone found a solution or can Zmodo support comment on if this is a known issue?


Update:

I went on-site to the location where the Zmodo system is installed. While on the LAN there, I could use ZViewer to see live video from each camera fine.Outside the LAN, I still could not view live video.

I saw the suggestion to open up the UPNP ports listed in the NVR’s network settings. I went ahead and enabled in my router port forwarding for these ports (for my NVR, Web Mapping Port = 33194, Video Mapping Port = 33195, Mobile Mapping Port = 33196) to the NVR’s IP address and same port number, but this still didn’t help with not being able to view live video remotely. I already have port forwarding setup on ports 80 (Web Port), 8000 (Video Port), 9000 (Mobile Port).

I can still playback video outside the LAN fine, although I ran into some other issue where I later couldn’t playback any video from any cameras and found that the NVR was saying that the hard drive in it wasn’t formatted! Will open up a separate thread on this issue.


#80

I have an Iphone and they just did an update on the IOS to 11 and now Zviewer does not work and it prompts me to do an upgrade. There is none presently and hasn’t been any for 4 years. I have a Zmodo DVR system that has cabled camera’s and I did enjoy the fact I could see my camera’s from anywhere now I got nothing. I tried Zsight and their other recommended app and nothing. I tried a plethora of other apps also and nothing, am I just dead in the water here?

Any help here would be greatly appreciated.

Note: None of the other apps that the Zviewer app writer recommends work for my Zmodo camera configuration.


#81

I was just reading a tech news post this morning about the fact that iOS11 will not run ANY 32 bit app and that you get the upgrade prompt. I have no idea if zmodo has a 64 bit version of the Apple app. You might check the apple store.


#82

@vader1701 @danwill This topic is about the Zviewer 2.0.1.5 PC software. Please begin a new thread for conversation about the iOS app.


#83

Danwill, I have tried your method of adding 8 cameras for my NVR sPOE ZP-NC18-S but only get grey boxes. In my Asus router I added an entry in port forwarding NVR with port 8000. Was there anything special you did to get your cameras to work?

Thanks in advance.