ZP-NE14-S auto upgrade


#21

In the meantime If a generous guy feeds me the 40.0.2.18 I will be grateful.
Since I cannot send pm message at now he should contact me first.
Thank you very much.


#22

Some people can send PMs, some can’t. Normally, above the “9 posts in topic” area there is a “Message” link. But not for all people. Not sure why.


#23

Was your device associated to your account in user.zmodo.com or in alternative to your account in zmodo app?
I think they are pushing the update from there.
Since once you register your device in your zmodo account the cloud service is activated automatically I think the zmodo server not being able to “talk in a secure way” to your ‘not updated’ device is forcing the update automatically.
Try to un-associate your device from your account to see what happens.
Let us know.


#24

Patty has said that the NVR is requesting the update from their p2p server.


#25

I’m not so sure about that.
NVR checks the presence of updates just when you open system settngs > software update tab.
So it’s not likely for me the NVR is checking and applying updates itself.
So I consider more probable the servers are pushing the update not being able to communicate in a secure way with the NVR… then… In other words, how their p2p servers can know about your device if not registered on their servers?
Not being able to put a block rule using the router I would give it a shot… just to see…


#26

Probably worth a shot.

EDIT: now deleted. Let’s see what happens next.


#27

How could you accomplish the downgrade at the end?
Using Zviewer?
Is it more safe than to use USB flash drive?


#28

The USB flash drive didn’t work this time - seems the downgrade via USB has been disabled now. More crap from Zmodo.


#29

Just found out about this automatic firmware update, which upgraded my ZP-NE14-S to V40.0.3.02. I’m very upset this was done without my permission. This should be opt-in. I cannot think of any product I’ve ever used that automatically updated firmware without asking for approval. I cannot use the ZViewer Windows program and IE to download video files anymore. I think if anyone tries downgrading the firmware again, it’s only a matter of time before it gets reverted by the automatic firmware update.


#30

Less than 24 hours is my guess,


#31

Right now when I get up in the morning I check and downgrade… Just another chore =]


#32

Well, Zmodo support responded to my query about preventing auto-updates by sending me yet another copy of the functional firmware, which of course I already have.

No mention of what I asked for.

[quote=Frank @Zmodo Support]attachment would be the firmware you need, might back it up to an empty USB driver and connect it to the NVR, get into the system setting, choose upgrade and select the file so as to upgrade it.
Please keep the system powered while updating[/quote]


#33

Did you check to make sure it was the same version you were already downgrading to? Maybe its an earlier one that won’t do it.


#34

The USB downgrade only works so many versions down. To use the USB downgrade, you would need to go to a more recent version.

The PC downgrade using either Zviewer or Zbatch has a much lower instance of bricking,and is preferable.


#35

Do we have a rough estimate on when the new Zviewer version will be available/ready?


#37

I had my functional system get auto upgraded to disable ZViewer on PC this morning. As a workaround to get Zviewer active again I forwarded port 8000 from each camera to be externally accessible & disabled DNS lookups on the ZMODO VLAN I have set up so that the system cant look up the update server.


#41

I have two units, one a brick from a failed FW attempt and a unit sitting with 40.0.2.7 that is not connected to the internet until I figure out which settings to set or disable within the unit itself. DDNS is not enabled on the NVR. Does anyone know for a fact what keeps the unit from accepting or asking for a FW upgrade?

I have v 40.0.2.17 on a USB but I wonder if I should even try to go from .7 to .17. I don’t want to brick another unit.

Separately, what is zmododns dot com?


#42

Thank you. That’s a valid solution of course at least to see the cameras.
Still remain the problem to access the recordings and all NVR settings, very comfortable from web interface.


#43

I’m almost in the same your situation.
2 units: one has been auto-upgraded some days ago and I cannot revert back even with the old firmware provided me by Zmodo support. I don’t know why. It says no firmware file present on usb flash drive (already tried different brands usb flash keys, freshly fat formatted connected in the correct usb port on the back panel). Also tried via Zviewer but it says ‘get shared memory failed’. Anyway it’s still functional but useless for me with the new fw.
The second unit (lukely I had one in stock brand new) replaced the first one. It has 4.0.2.14.
Blocked access to zmodo.com domain via firewall from it’s internal ip.
At now it’s working already 2 days without being auto update.
On the same time I’m afraid to manually upgrade to 40.0.2.18 because it’s the last functional unit I have :-/

p.s To prevent auto update I also didn’t register the new unit in my zmodo account.


#44

I think it’s not the unit asking the update. Otherwise all the units around with old firmware would already asked the new firmware many months ago when it was released.
I think zmodo servers are pushing the update since the cloud service is not able to comminucate with the old firmware units in a secure and safe way.
IMHO would be enough not to register the unit in your cloud account to prevent their server to push the update.
But I’m not 100% sure about that.
Shambles is testing this context since he cannot block the internet access via firewall like I made.