MeShare App Alerts Extremely Slow

Is anybody else having an issue with the MeShare app? Supposedly, there was a bug in the Zmodo app, and people were encouraged to use the MeShare app.

I’ve noticed since I’ve switched, the alerts load up extremely slow. They used to load up within 3 seconds, and I’m waiting upwards of 2 minutes now if it doesn’t timeout.

Is this what the future of this company/app is? You introduce cloud services, and it’s bugged from the beginning. It has also reduced the functionality of the system for absolutely no reason.

Cloud services are currently only offered as a “Beta” release, if you are choosing to take part in the beta testing, as with most beta test products. There are bugs.

Please send an email to our support team with your device information, phone model, and cell carrier. We can then log the issue and forward it on to the development team in the hopes that any issues can be resolved prior to the full launch.

That’s the thing…I didn’t enroll in the beta, but my app is extremely slow still. The live images load up just fine, but to view the alerts is taking several times longer than it used to. What would cause that cause nothing has changed on my end. It even happens when I’m connected to my home WiFi though it isn’t as bad.

Im also experiencing sluggishness on the meshare website, device alerts take time to load as if I was on dial up. Getting 502 bad getaway error.

As of today, it’s still extremely slow. There’s no reason that the app should timeout while I’m trying to load the alerts. Matter of fact, this issue only started after the Zmodo update.

Is this how Zmodo plans to attract consumers to their cloud services? By providing subpar functionality in their app?

If you can’t do it correct at the most basic level, I guarantee your success at a higher level will be minimal. If they even manage to get any success.

It literally takes over a minute to load the alerts. Numerous timeout prompts, failure prompts. Nothing on my end has changed as stated before. This is all on the Zmodo side.

The site seems to be up and running now. Its not that slow anymore for now.

Also I noticed that my notifications are only stored for 24 hours since im not subscribed to the cloud, but I have an NVR. Are we being penalized by not having cloud service? when in fact unlimited notifications were stored on the cloud for free before the new service was introduced?

I noticed that for iOS, they updated the app. I’m assuming that’s what was causing the extreme slowness/lag.

I chose not to upgrade my app though, because it always broke the functionality for me. Also, iOS makes it extremely difficult to downgrade, if at all.

And I spoke way too soon. The MeShare was functional yesterday, but it’s completely bricked as of this morning. You can’t turn on device notifications, or turn on the alerts due to the fact that it ends up timing out.

It’s also impossible to bring up a live feed now which results in me having to download the STILL buggy Zmodo app in the meantime for a live stream, but there’s no alternative for my alerts. From what I’ve experienced, the new Zmodo app doesn’t even register sound alerts anymore; only motion.

So, is the MeShare app being worked on which is why it’s bugged again? Or is this a ploy to make people upgrade their software?

I’d rather not see a 3-4 sentence from the moderator which doesn’t address the issues I’ve talked about. If you don’t read the whole post, a reply becomes redundant.

With WIFI connection ! You can not expect it works like thunder.( have to wait ).

Hi,

I’ve just found out that there is a bug with Android ZMODO App. It appears that the app once in the background, with time it looses the connection to the server and hence it stops receiving alerts.

Initially I thought it was the camera, but no. I’ve shared my camera with an Iphone and after leaving the the Android App in the background, I only get notifications in Iphone and not in Android. If I re-login to Android, I get notifications back on both.

This was tested with Android 6.0.1 replicated on two devices: Samsung Galaxy S6 and Samsung Galaxy Tab T700.

Would be great to get a fix!

That sounds like it may be the Doze setting.

Hi Patty,

Thanks for the info… I didn’t know about it. I went out and checked my Doze settings and it was enabled for ZMODO APP. These are the changes I made for ZMODO App:

  • in Optimise battery usage: Not optimised.
  • in App power saving: disabled

I’ve tested again with the same result. if the phone enters standby / sleep mode, I stop receiving notifications in Android. If I leave the phone running (screen on)… all good.

Any other thoughts?

I think you have to set the Zmodo app as a high priority app in order for the phone to pay attention to it during doze time.

Hi Patty,

It is already in that mode… I’ve done further testing and I think it is related to the doze mode. If I leave the phone charging, I do get all alerts (even if I’m not using the phone). So it looks like it is something related to how the app works with the doze mode.

I will test it tonight in battery mode and with the 4G to see how it works.

Hi Patty,

Definitely there is an issue with the way Zmodo app handles the doze mode. It appears that messaging needs to use another delivery system if they are considered critical.

4G and wireless shows the same results.

Do you think this can be raised a defect?