EMail Alert not working


#1

Dear Support,

my EMail Alerts are not working. I try to setup an Account using “Service Provider” Other, but the system will return an error in authentocation every time I try to test the setup.

I double checked the credentials several times. To see what happens I installed an email relay on my notebook and traced the network communication using wireshark. It points out that although I’ve entered “user@domain.tld” in the From field my NVR will only send “user” during the authentication attempt. So for whatever reason my NVR will cut everything starting with the first @ sign.

Please help fixing this issue.

My NVR is a ZP-NC18-S running firmware V43.0.1.12.

Kind regards.


#2

I tried to dig deeper into the issue. Another problem is, that if the password is to long the NVR will truncate this one as well. 12 characters was ok for me, 16 was to long.

One possible workaround, which works for me as my mail provider accepts this option, is to user an alternative user name. According to my provider older mail clients use the % sign instead of @ - so I entered the username: “user%domain.tld@domain.tld”. During authentication process “@domain.tld” is stripped off, but so the username send is “user%domain.tld” which is accepted. I added “@domain.tld” because the GUI of my NVR requires a “valid” mail address.

BTW: This special user string is only accepted when entering it thorugh the GUI of the Box. The Web GUI won’t accept this string.

Nevertheless, this needs urgently fixed by zmodo!

KR


#3

Please reference our Previous thread about email alerts

We are aware of the issue, and also aware of the available solutions.

Unfortunately the development team has not indicated if email alerts are something that we are going to support moving forward. Once there has been an official determination, I will post it on the forum.

Until then, please contact our phone based support with any questions or concerns regarding email alerts, when calling, you can also request to be added to the list to receive an email once the official determination has been made.

We are available from Monday-Friday, 8am-7pm CST, and can be reached at 217-903-5037.


Problems with ZMD-DX-SAN8
#4

Patty,

thanks for the information. But sorry, I was not able to find how to resolve my issue on your website. So if you’re aware of a solution it would be great to mention it, especially if you close a thread.

If possible, please add me to this notification list as I won’t call a US support no. from europe.

To be honest it’s imho quiet strange and not very customer friendly that you need 5 months to investigate such a simple error and up to now you’re far away of having a solution. No, you’re even thinking about discontinuing this feature. Sorry, but if zmodo will drop this feature I will return my NVR to amazon as you’re not providing a warranted key feature.

KR


#5

I just got my DVR installed yesterday and find out that the email will not work. This is not the kind of thing you want in a newly purchased product. I am going to have to think this over today, if I want to pull all the wiring out and send it back for a refund.


#7

#8

If the email alerts are an absolutely essential feature, and the app based alerts do not seem like something that could serve as a sufficient replacement, then I would recommend contacting your seller and requesting a refund on that basis.

Some sellers only allow for returns within a specified time period, and we do not have specific confirmation that the email alerts will be updated to comply with the new standards.


#9

Agreed with all above…the EMAIL ALERT in my POV
is WAY better, fast and i get more SNAPSHOTS
than the 1 or 2 ZMODO/ZSIGHT/MESHARE apps give.
The EMAIL alerts are a MUST for this system to really be a good investment,
even more since it’s just a SOFTWARE change, and we already HAD it b4,
and was/is a reason we paid for the product.
Ive installed 4 of your “systems” for myself/friends with this feature and now they dont have it, neither do I


#10

After months claiming all users and customers of products Zmodo finally you have decided not resolve the problem, great, phenomenon.

I applaud your service! Plas Plas!

Now I regret not having bought the IP camera Xiaomi.

Incompetent!!!


#11

This is absolutely ridiculous! As a business owner, and one that has provided the service of installing this system into TWO other businesses in town, you better fix this issue or else I’m screwed out of $1000+ since I will soon have to refund their money, and spend money out of my own pocket to have my guys now take out these systems. And will most likely lose all business from them after this whole ordeal.

This is not a hard problem to fix! I can fix this myself within a few minutes if I had access. My business is a computer store, I’m a computer technician, with programming and hardware certifications.


#12

As of right now, there are units available on Amazon, Newegg and I’m sure many other sites that still offer email notifications. In fact, even the zmodo site shows systems that offer email notification. This is false advertising and against the law.

I have to agree, that something like this is VERY easy to fix. I just don’t understand why it isn’t fixed. Nothing has changed as far as security for google, yahoo, etc. for quite a few months. Nothing magically happened other than something went wrong at the zmodo end.


#13

Using Zviewer I can add the IPC cameras from my ZP-BE-14S. I can setup my yahoo account and it sends a test email successfully. The cameras sense motion correctly since I see an orange bar in the timeline. So why doesn’t it send an email when there is motion, only when performing a test.

That indicates the issue is not some email setting but rather something at my end. Suggestion?


#14

@racerfern
You are incorrect, something did happen with the email providers. They updated their SMTP security requirements, and as a result, the email requests that were working previously, are no longer accepted by the servers, given their new security requirements.

The reason the test send from ZViewer works, and the send from the device itself does not work, is because the Zviewer software was developed in line with the new security requirements, so it is able to send, where the system is not.

The emails still send through servers with the older, outdated security profiles, unfortunately, most people do not have access to SMTP servers with the outdated security requirements.


#15

Patty,

Your answer almost makes sense to me although something doesn’t sit quite right. However, since the real issue is getting emails working, what is being done about that?

If I leave Zviewer running all the time and recording to a PC HDD, can it send email notifications instead of the zmodo box? Are there other possibilities that might work?


#16

The Zviewer software doesn’t detect motion, so it cannot send the alerts on its own. Currently there is not a solution to the email alerts not functioning beyond locating a server that will allow the older authentication types.


#17

Patty,

soory, I still have some doubts regarding the mail server protocol conspiration. Can you specify which kind of protocol change of all mail servers world wide has broken zmodos mail functionality?

For me the easiest fix would be to get rid of the stupid truncation of the “mail from”-field. Send the full user name instead of truncating @domain.tld - this is what most servers will accept. If you want to solve the issue correctly, just add a seperate user name field, which can be used for authentication.

And for sure get rid of the erroneous truncation of the base64 encoded password.

After that, everything will work as expected. For a experienced programmer both changes shouldn’t take more than one hour including testing. So what’s the problem implementing such a fix?

KR


#18

I got mine working by switching to my optimum.net account. It may be that other cable providers also have allowances for legacy systems.

Their instructions call for a secure connection with port 465 like most others but they also allow for unsecure using port 587. It worked.

However the screenshot is useless. Any suggestions?


#19

The update was to the SMTP request authentication requirements.
Below is a link to the Google forum thread where the issue is discussed. A Google representative explains the changes that they have made to the SMTP authentication requirements.
https://productforums.google.com/forum/#!msg/gmail/2tK2fR7yW-k/CT5u-VBpgp8J


#20

That almost looks like the motion was triggered by a video stream error. Could you forward the email over to support@zmodo.com with your username and attn:Patty as the subject line?


#21

Patty,

thanks for the information you’ve provided. But sorry, this change you’re referecning is a change in the MAIL FROM

Yes, in the past week we’ve rolled out a change which enforced validation of the MAIL FROM argument to be a valid RFC 5321 email address.

We’re experiencing authentication issues - MAIL FROM verification happens two or three steps after the authentication.

The issue ZMODO has, it strips the domain name during the authentication process. So imagine your email is patty@zmodo.com the NVR just sends patty as user name. But as your email provider might host hundreds or thousands of other domain there might be also a user patty@domain1.com and/or patty@domain888.com. So the mail providor needs the complete address to be able to find/match the account. So unfortunately your just delivering half of the required information.

KR